[07/03] - Firefox 52 no longer supports Java

The latest version of Firefox no longer supports NPAPI Plugins except for Adobe Flash. As a result, Java is not supported in the latest version of Firefox and so cannot be used to play RuneScape.

For the best experience, download the RuneScape game client: 

Download Game Client

Was this article helpful?